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Abstract: 
 
This workflow will highlight the basic necessary steps of using the Roadway Designer: Creating corridors, 
creating/modifying templates, talk about styles and symbologies, define the difference between a 
component and a point, assigning templates to a corridor or template drop, defining transitions or other 
horizontal or vertical controls, test and refine our Roadway and finally create a surface. 
 
This workflow is designed as a reference and to establish future workflows, to get you started. It is not a 
step by step show you everything approach. It hits the highlights. 
 
This workflow does not address the creation or modification of horizontal and vertical alignments nor the 
evaluation of the surface created by this process – displaying contours, creating cut/fill maps, earthworks, 
etc. 
 
Also, if this is your first venture using the new Roadway Designer it is highly recommend running through 
the basic InRoads Roadway Designer Tutorial. We will refere to this tutorial throughout this document. 
The instructions and sample files are on your computer. Open the pdf file located: 
C:\Program Files\Bentley\InRoads Group 
8.8\Sample\DataInRoadsRoadwayDesignerTutorialV88(Imperial).pdf 
 
Run through pages  77-102, and 112(Applying Point Controls) - 126 of the Roadway Designer Tutorial. 
The skipped middle section is on Superelevation, if this is applicable to you please run through the entire 
tutorial. 
 
It should take about 3.0 hours of uninterrupted time to complete the lesson (not including the 
superelevation portion). 
 
Tools talked about during this workflow can be found under the Modeler menu item within InRoads. 
 
Software Version: InRoads V8.8 
 
Notes: 
 

Vocabulary Lesson: Old terms -> New Terms 
Typical Section -> Template 
Roadway -> Corridor 
*.rwd -> *.ird = Roadway Design File 
*.tml -> *.itl = Template Library  

 
Roadway Designer vs Express Modeler 

Roadway Designer -- generates a 3-D corridor model, incorporating independent controls, following 
right-of-way restrictions, and applying superelevation. 
 
Express Modeler -- Use this command as a simple and direct method to move a specific template 
along an alignment and create a surface from the results.  The new design surfaces can represent 
a new roadway or other type of surface.  Express Modeler is intended for models that do not 
require the depth of information provided by Roadway Designer. It does not have any mechanism 
to incorporate independent control, superelevation, or right-of-ways. For the generation of complex 
corridor models, use the Roadway Designer command. Use Express for berms, ditches, simple 
roadways, etc. 
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Instructions: 
 
The Roadway Designer workflow consists of six main tasks 
 

1) Create the Corridor/s 
2) Create the Template/s 
3) Template Drops 
4) Special Conditions (a. Transitions, b. Point Controls or constraints, c. Superelevation) 
5) Test and Refine 
6) Create Surface/Display Features 

 
Create the Corridor/s 
 
Road design begins with creating the roadway corridor. A project must have one or more corridors 
to create a valid design from which a surface can be created. 
 
In the past we would create the template then the Roadway. We want to now reverse that mindset. 
 
1. Click Modeler > Roadway Designer. 
 This opens the Roadway Designer dialog box. This is where you will manage, create and refine 
your corridors. 
 

 

PLAN VIEW

CROSS SECTION 
VIEW 

PROFILE VIEW

 
The top-left window is the plan view and displays the alignment (baseline) of the active 
corridor in light blue. The active surface perimeter is shown in white; the current station 
location is shown as a yellow line. The bottom-left window is the profile view. The large, 
top-right window is the cross-section view. 
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Transition 
Zone 

Limits of Active 
Corridor Design Template Drops 

Limits of Active 
Surface

Display Reference 

Active Corridor 
Alignment 

PLAN VIEW

Active Corridor 
Alignment 

Active Surface

 
PROFILE VIEW 

 
2. Next, create the new corridor. Click the Manage Corridors  button. For Name, type 
the name of your corridor RoadwayRoute1 or Street A. 
 
3. Click Add. 

 
 
Notice the PI Rounding Tangent field.  This field is used to define a tangent length to use when 
processing a feature or an alignment that does not have curves at the PI points.  In those cases, a 
pseudo curve is created with the specified tangent length along each segment.   Then, the roadway 
design processing is orthogonal to the curve instead of the alignment, although the centerline of the 
corridor remains unchanged. 
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Notice that you can add, edit, or delete corridors from your design at any time during the design 
session from this dialog. You can also copy corridors from other Roadway libraries (ird files). 
 
4. Close the dialog. 

5. Fit the view  . 
 
Create the Template/s 
 
Within the InRoads Help type in Create Template Overview in the search tab for further detailed 
information. 
 

When attempting your first Template, please load InRoads, go to the Help, click on the 
contents tab, scroll down to Media Library and select Creating a Simple Roadway 
Template. This is a short video showing the basics of the Create Template dialog. There 
is no sound but very worthwhile to run through. 

 
Getting started we will focus on Constrained components and End Conditions. See Appendix A for a 
complete description of Template Components. 
 
Ok, a couple rules of thumb. 
 

a) If you are not sure where a command is, try right clicking 
b) The difference between a component and a point: A component is part of your typical section; 

for example the asphalt. The component is then comprised of points. For example Crown and 
Edge of Pavement are two points of our asphalt component. Points represent the breaklines 
when displayed in plan view. Breaklines are features in a surface. The display of the feature is 
controlled by a Style. When placing components and points, make sure you pick the correct style. 
This will ensure that when you display graphics they appear with the correct color and on the 
correct level. You can always change the style by double clicking on your component or point 
after you place them. Alternatively, try right clicking on a component or point. It is important 
to select the appropriate style. The settings of the style not only control color and level, but 
fi the feature will even display. A style for example could be setup to only display in Profile View 
and as such wouldn’t even show up on plan when trying to display. 

c) Dynamic Settings are your friend.  See Appendix B for additional Dynamic Settings info 
and a slightly more humorous lesson. Otherwise keep reading to get started. 
 
Find the  button. Click it and the Dynamic Settings box will appear. You can also use Ctrl+D. 
YOU WILL USE THIS A LOT!! Notice on your create template screen there is a small purple, 
square. When you start it is probably at 0,0. With the dynamic settings box, click on the Set 
Dynamic Origin. You can now place the small purple square 
anywhere on your template. This is the Origin to move in the 
x,y direction or in the x, slope direction. Click on the X:   Y: 
button and it will shift to X:   Slope:. The step is just that. If you 
want a 12’ wide section at 2% (signs don’t matter!!) 
Positive/negative directions are based upon the location of your 
mouse cursor with respect to the origin (small purple box). 
While your mouse is moving, notice the dynamic settings, the X:   
Y: will update instantaneously only at the intervals of your 
steps.  

 
This is mostly straightforward. You want to move 10’ in the X and 2’ in the Y; type those into 
your Step values. The only tricky part is if you want to move in a cardinal direction or at a flat 
slope. DO NOT ENTER A VALUE OF “0”. Enter a larger value say like 5’ or 5%, then when you are 
moving your cursor, one of the dynamic values(step values) will be 0 and it will lock in there. If 

Page 4 of 14 



you set it to 0, then all values are valid dynamic values(step values) and it is difficult to get the 
exact value you are looking for. 

 
d) If you build it once, don’t build it again!!! Templates are now very easy to use over and over 

again. Items such as curbs, medians, fill conditions and pavement sections can be used over and 
over again. For example you can build several different curb types as a template by themselves. 
Then when you need it, you can drag and drop it  on your new template. You can also easily 
copy templates from other libraries into your active one by using the Tools -> Template Library 
Organizer. You can also organize your library in a similar fashion. Have individual folders for 
Curbs, End Conditions, Sections. Then have one library titled Templates that have your complete 
templates for your job. Think of templates as standards. There will be a seed template library in 
your newjob folder. Also, you can import *.tml files from older versions of InRoads to help start 
your new libraries on existing jobs. 

e) Name and set your Style of your components and points while you go. 
1. Right click and Add New Component 
2. Name\style your component at the bottom of the screen 
3. In the Dynamic Settings, Pick your Point Name or give a new one and set your style 
4. Place your point 

f) If using Constrained components do not string them together. 
What? Do not go from crown, to ep, to flowline, to tc with a single component, keep them 
separate. Go from crown to ep, right click Finish, then start a new component for ep to 
flowline. This is necessary for graphic purposes as well as if you intend to use variable width 
templates. 

 
Ok enough rule of thumbs lets try this thing: 
 

1. Modeler -> Create Template 
This opens the Create Template dialog box. This is where you will build each of your End 
Conditions, Misc Components (curbs), Pavement Sections and of course complete 
templates. 
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2. Open an existing library or create a new one. File > New > Template Library 
3. Right-click, a dynamic menu will appear with options for New > Folder; name “templates”. 
4. Right-click on Templates to display an additional dynamic menu with options for New > 

Template. 
5. Name the new template.  
6. Since you have added a new template, save the 

library file. 
7. Click File > Save As. 
8. For Save as type, select Template Libraries (*.itl). 
9. Type in name of your template library 
Zooming Around 
 You can use the zoom in, zoom out, fit all or your 
center mouse wheel just as in Microstation to zoom 
around your template or roadway design. Notice the 
zoom controls at the lower left corner of the template 
window. 
Undo/Redo 
 Next to the view commands, notice the Undo Redo commands. These are awesome. 
To add new components 
10. You can now drag and drop from existing already built templates or begin creating your own 

components. 
11. Right click in the template window, select Add New Component, pick component type. See 

Appendix A for a complete list and description of component types. Using a “simple” component 
you will simply put in the width, slope and depth at the bottom on the template window. If you 
are placing the others you will typically use the Dynamic Settings to place it. 

12. Click Tools > Dynamic Settings. The settings here allow you to specify precision input (step 
increments) from the dynamic origin of the new template. See 
using Dynamic Settings in Appendix B. 

13. Repeat to finish your template. 
14. Add End Conditions. We will add a simple cut and fill option on 

each side of the template. You can also construct complex 
bench/wall scenarios as well. 

15. Right click in the template window, select Add New Component, 
pick End Condition. Set your component style; imp_cut. Right-
click and select Mirror. Move your cursor over the end of your last 
template component where your cut will begin, left mouse click. 

16. Now use your dynamic settings to set your slope and x direction, 
Cut as Point name and click the checkbox End Condition is 
Infinite. First, selection the Set Dynamic Origin. Relocate the 
origin to the beginning of your cut line (end of your template) 
and left click. Move your mouse cursor to where the slope should 
appear, watch your dynamic settings box when you hit your slope 
and direction criteria, left click in the window. 

17. Finally, right-click and select finish. Notice that the cut line was drawn on both sides of your 
template. 

18. Repeat for the fill line. When setting your component style to imp_fill, there is a priority box, set 
the fill priority to 2. 

19. Click File > Save 
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Template Drops 
 
Now that we have our corridor and templates created we need to associate them. This is called 
“Template Drops.”  
 
Back in the Roadway Designer 

1. Click the Template Drops button . 
2. In the Library Templates tree view, select Templates > <select the desired template> 
3. Make sure the correct corridor is 

selected. Watch this closely, as it 
appears as if the drop down box 
changes quite easily. 

4. Set you initial station, the station 
shown is the beginning station of the 
alignment. 

5. Set an interval of 10 (the template is 
placed every 10 feet). Consult your 
Project Engineer for proper setting. 

6. Click Add. 
7. Repeat if roadway is using another 

template that will incorporate a 
transition. 

8. Place the same initial template at the 
start of where the transition is to 
begin. Place the other template at 
the station where the transition is to 
end. 

 
Lets take a moment here to discuss what is exactly happening when you add a template drop. When you 
select a template to associate with a roadway, it is actually copied to the Corridor or Roadway Design file 
(IRD). On the figure above notice the “Revised in” tab. It tells you where the template came from. ITL = 
template library. IRD = Roadway Design file. You can make modifications to a template in a specific 
roadway and it won’t change the template library. The “Revised in” will show IRD.  Conversely, you could 
change the template library and the Roadway will not reflect the changes unless you highlight the 
template drop and select “Sychronize with Library.”  
 
Special Conditions and Transition Editing 

Our next step is to take care of any transitions and add any special conditions, other constraints and add 
any Superelevation. This part of the Workflow is for reference only and will not step through the 
necessary steps.  If you care to have an example of how to use the Transition Editing, Horizontal and 
Vertical Point Controls, End Condition Exceptions, End Condition Exception Overrides or Superelevation 
please refer to the Roadway Designer Tutorial (info at the beginning of this document how to access the 
tutorial) and the online Help. Use keyword: Roadway Designer Overview.  

A transition zone is created between templates of different names.  The 
color of the transition zone indicates the state of the transition. This is 
display in the plan view of the Roadway Designer. 

• Red – indicates that none of the backbone points of the first 
template connect to the backbone points of the second template. 

• Yellow - indicates that some of the backbone points are 
connected (initially this is done attaching points that have the same name. 
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• Light Blue – indicates that not all of the points are connected, but you have reviewed and/or 
edited the transition at least once. 

• Dark Blue – indicates that all of the points on both templates are connected. 

A transition can be edited by double clicking on it; the Edit Transition dialog box is displayed: 

Transition Editing 

Editing a transition is a two-step 
process.  The first step is to connect 
the backbone points of the first 
template to the backbone points of 
the second template, as desired.  
Unconnected points are shown as 
thick + symbols; connected points 
are thin + symbols.  Note that End 
conditions are not shown.  End 
condition transitions are handled 
through end condition exceptions. 

Connecting the points 

There are several things to be 
aware of when connecting points.  A 
connection is created by clicking on 
an unconnected point on one 
template then moving the mouse to 
a point on the other template; then, 
clicking again.  The connection line 
will be shown dynamically.  To abort 
a connect, press the right mouse 
button. 

The order of point selection is 
important, because the feature style 
that will be used when this 
particular line is created in the 
surface will be the feature style of the first point selected. 

A connection can be deleted by right clicking on it and selecting the Delete command from the pop-up 
menu. 

You can change the position of a template by right clicking on one of its points, selecting Move Template, 
and dragging the template to a new location on the screen.  This, along with the windowing commands, 
allows you to get a better view of the connections.  This is particularly useful for complex templates. 

A template point can be connected to more than one point on the other template. 

Editing the transition components 

Once the points have been connected as desired and the OK button is selected, the command attempts 
to create the components for the transition based on the start and end templates.  The results of this 
“best guess” is displayed in the window as shown below.  You can modify the transition template as 
desired by clicking Cancel and returning to the Edit Transition dialog box. 
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The display shows a cross section of the 
transition half-way between the template 
drops that define the transition.  The 
slider control at the bottom of the dialog 
box is used to adjust the location along 
the transition from beginning to end to 
make sure the transition is behaving 
properly.  You can add a new component 
by right clicking anywhere in the view; 
then, you are prompted to select the 
points that define the component.  Finish 
up the component by right clicking again 
and selecting Finish.  When selecting 
points, you are limited to only the existing 
points, and cannot create new ones. A 
component can be deleted by right 
clicking on it and selecting delete. 

When everything is correct, select OK 
again to dismiss the dialog box.  If you 
select Cancel at this point, you are 
brought back to the connect points 
window. 

 
 

Horizontal and Vertical Point Controls 

Point controls are used to override the normal locations of one or more points and or components in a 
cross section.  Examples of this include lane widening, staying within the right-of-way, maintaining a 
particular slope for a ditch, and superelevation. Click Corridor > Point Controls. 

Using End Condition Exceptions 

In many cases, it is desirable to keep the backbone of the road the same, but change what is happening 
where the new design is intersecting the surface.  One way to do this is to create a new template with 
the same backbone components and new or different end condition components; then, drop this new 
template at the appropriate station.  The problem with this approach is that 1) it creates template 
transitions that must be resolved, 2) the conditions on the left and right sides of the design are likely to 
change at different locations, possibly requiring extensive collection of slightly varying templates to meet 
all the possible combinations (also numerous template drops).  The solution to this situation is End 
Condition Exceptions. End condition exceptions come in two classes: overrides and transitions. Click 
Corridor > End Condition Exceptions. 

End Condition Exception Overrides 

Overrides allow you to replace or override the template drop end conditions on the left or right of the 
backbone.  When you choose this option, you must edit the override to set up the new end condition.  
When the override exception is edited, the Create Template command dialog box is displayed allowing 
you to edit the end-condition. 
 
Superelevation 
 
If required, please refer to the Roadway Design Tutorial and InRoads help for further information. 
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Test and Refine 
 
Continue the process of setting transitions, adding point controls, end conditions, superelevation until 
results are what you desire. The corridor can be saved and returned to for future editing at any time. 
 
Use the process all button to have the complete corridor run through each station. 
 
On the cross section view of the Roadway Designer, click through the stations to watch your template run 
throughout the alignment. Notice how the cut/fill slopes are dynamically changing throughout the 
alignment. 
 
Use Display References to show any horizontal constraints on your roadway such as utility crossings, 
property boundaries or right of ways. When selecting a horizontal alignment as a Display Reference, 
make sure you mark it as right of way. This will show dashed purple lines in the cross-section view of the 
roadway designer. Go to Corridor -> Display Reference… 
 
If you have a station that you wish to see a template run, meaning a station that falls between the 
station interval set for the corridor. You can set it as a Key Station. Go to Corridor -> Key Stations… 
 
Create Surface/Display Features 
 
Typically, the end result of a session in the Roadway 
Designer is the generation of a new design 
surface from which plan, profile, and cross section 
drawings are created. Using the Create 
Surface command, you can either create a unified or 
merged surface from all corridors in a design, 
or create a separate surface for each corridor, which 
you will complete in this task. 
 

1. Click . 
2. Select the settings as shown below: 

• If you wish features to display, the 
Breaklines of your road, check “Display 
Features in Plan View”. Alternatively, you 
can create the surface then use the 
Surface -> View Surface -> Features 
command to selectively display 
individually selected features or groups of 
features based upon the feature style. 

3. Click Apply; then, Close 
4. Once processing is complete, save the 

roadway design file. Close the Results dialog 
and the Roadway Designer. 

5. In the Explorer, locate the new design 
surface. 

6. Review the surface. 
7. Save the surface if desired. Refer to the 

Cadd Standards and Procedures manual for 
proper naming of dtm files. Section 3 - 
“Filenames”.  
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Appendix A 

Template Components 

A component is a set of points that define an open or closed shape. Each component, whether open or 
closed, can represent a different material or area of interest.  Components are named and have an 
assigned feature style. There are 5 types of components created in InRoads: Simple, Constrained, 
Unconstrained, Null Point, and End Condition. 

A simple component typically represents a section of pavement. It’s a closed parallelogram (4 
constrained points) that is defined by the slope and thickness.  

A constrained component consists of points that are all restricted to the movement of the first point. A 
constrained point is typically used to manage the behavior of other points in the template.  When a point 
(parent) is moved, any constrained point (child) also moves. This restriction only affects the offset and 
elevation (x,y) of the restrained point and, the relationship is unidirectional (movement of child point 
does not move the parent point).  

An unconstrained component is open or closed-shaped with no movement restrictions.   

A null point is a template point that is purposely not related to any particular component.  It’s most 
often used as a reference for controlling other points.  

An end condition is a special open-shaped component that targets a surface, a feature of a surface, an 
elevation, or an alignment (it replaces the former Cut/Fill, Material, and Decision tables).  The integrity of 
end conditions can now be routinely tested while the roadway template is being created.  

Once created, components can be modified as desired. There is no limit to the number of points or 
components in a template. When templates are paired with horizontal and vertical alignments and 
superelevation, they define the surface of a corridor. Templates are flexible design components that allow 
you to model simple constructs such as ditches and sidewalks to the more complex multi-lane highways 
with superelevated curves and variable side slopes. 
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Appendix B 
 
Dynamic Settings 
 
Ok, most of the text below is straight out of the help file from InRoads. It is good for some simple 
definitions, but misses the whole “How do we use this?” concept. We want to emphasize a couple of 
concepts first and they should help your experience with the Dynamic Settings out. YOU WILL USE THIS 
A LOT!!!! 

To open the box go to Tools->Dynamic Settings, or click on the  button, 
or use Ctrl+D. The first item to point out (it is the last in the help file) is the 
Dynamic Origin. Take a look at your Create Template window, do you see the 

small purple box? No…it looks like this:   It is exactly what it says. It is 
the origin of the Dynamic Settings. Meaning if you tell a component of the 
template to be 12’ in the X direction and 0.24’ in the Y direction. It will be 
from this purple box! 
 
The Dynamic part is just that as well, it can MOVE. You can place this purple 
box wherever you want it. So after you draw in your pavement section and 

want to place you next component that may be the curb, you will hit the Set Dynamic Origin, 

 , relocate the little purple box to the end of the pavement section. It will automatically 
snap to the end of it when you get near, now you will tell InRoads the dimensions of the component. 
 
You can give dimensions in two forms. With Step Values(deltas) or absolutes. We are only going to talk 
about deltas, the absolute functions are more straight forward and can be read about below. You may 
wish to print out the key-ins and tape on your monitor for reference. 
 
OK… Delta X:Y or Delta X:Slope are your tools. First concept, don’t worry about positive or negative. The 
direction will be from the location of your mouse pointer. Meaning if you are right/above of the origin the 
delta value will be positive, if you are left/below of the origin the delta value will be negative. You get the 
point. Same goes for slope. Above the origin > positive, below the origin > negative. So don’t key in any 
negative slopes, it just isn’t necessary. 
 
Second concept: this is the weird one. When you want to move in a cardinal direction (north/south or 
east/west) or at a flat slope. DO NOT ENTER A VALUE OF “0”. Enter a larger value say like 5’ or 5% or 
even larger numbers. Then when you are moving your cursor, one of the dynamic values(step values) 
will be 0 and it will lock in there. If you set your step value to 0, then all values are valid dynamic 
values(step values) and it is difficult to get the exact value you are looking for. Actually it will drive you 
crazy, you think you are doing everything correctly but a slope is off or a section is one foot longer then it 
is supposed to be, not good. 
 
Ok…try it out now. Try drawing a new component; select Constrained as the component type. Draw two 
new components. One that is 12’ wide and .24 down from the beginning. Draw a second new component 
that is 12’ wide and slopes down at 2%. 
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Below is the Inroads Help info…it is very useful for definitions and the such. 

Use this dialog box to specify precision input.  Step locks are overridden when snapping to an existing 
point or component. 

X:Y/X:Slope 

toggles between X,Y step lock and X/Slope step lock. 

X Value 

displays the current X distance from the dynamic origin. 

X Step 

specifies the step increment. If this value is non-zero, then the cursor moves to the horizontal increments 
of the specified value as measured from the dynamic origin.  

Y value 

displays the current Y distance from the dynamic origin. 

Y Step 

specifies the step increment.  If this value is non-zero, then the cursor moves to the vertical increments 
of the specified value as measured from the dynamic origin.  

Check for Interception 

Place Point at  Interception 

applies to end condition points only.  Specifies that when an interception is found along the preceding 
line segment, the line segment will be drawn to the interception.  Otherwise, if the interception is found, 
the line segment will be drawn to its maximum width. 

End Condition is Infinite 

applies to end condition points only.  Specifies the last segment will be considered to be of infinite length 
when attempting to intercept the target. This option is only applicable to the last point on the end 
condition. 

Do Not Construct 

applies to end condition points only.  Specifies the point will be solved like all other points in the end-
condition, but the point will be skipped when drawing the component segments. 

Point Name 

specifies the name of the point to be placed. 

Point Style 

allows you to set the style of the point to be placed. 

Apply Affixes 

specifies, when selected, that affixes are applied when placing points. 

(key in) 
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specifies the type of key in to be performed. 

• XY= key in absolute coordinates 

• DL= key in delta coordinates from last point placed (defaults to the dynamic origin if it is the first 
point of a component. 

• HS= key in horizontal delta distance and slope from last point placed. 

• VS= key in vertical delta distance and slope from last point placed. 

• OL= key in delta coordinates from dynamic origin. 

• OS= key in horizontal delta distance and slope from dynamic origin. 

(key-in) 

specifies a precision value.  If the key-in value is prefaced with a key in type (e.g. “DL=”), then the keyed 
in type overrides the current combo box setting.  Press the Tab or Enter key to accept the value in the 
field and apply it to the current operation; then, the field will be cleared and focus will remain in the 
field.  You can also use the up and down arrow keys to get to previous keyed in values. 

Set Dynamic Origin 

sets the location of the dynamic origin.  Use the following short-cuts for this option: Crtl+D. 
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